Enigmes

Forum dédié aux énigmes et à toutes formes de jeux de logique.

Déconnexion

Tu n'es pas identifié sur Prise2tete : s'identifier.

accueil Accueil forum Forum
[+]

 #1 - 16-06-2012 21:16:48

Seanbateman
Professionnel de Prise2Tete
Enigmes résolues : 21
Messages : 321
Lieu: Toujours à l'énigme 3

p2t rxcel (argh!)

Voilà bientôt 2 heures que je me prends la tête sur une BIP de fichier excel, ce truc va me rendre dingue lol

Je me suis lancé dans un gros chantier de rationalisation d'informations présentes sur un fichier excel, le but ? Trier des informations en fonction d'un Rank pensait par mes soins. Alors sur le papier, d'un point de vu mathématique, pas de problème, mais excel quoi !

Je vous présente le calcul de manière simple :

Data 1         Score
>=0 et <=1000                 0
>1000 et <=10000         1
>10000 et <=50000         2
>50000 et <=100000         3
>100000                        4
   
Data 2         Score
=0 OR vide                 0
>=1 et <=50                 1
>50 et <=100                 2
>100 et <=200                 3
>200 et <=500                 4
>500                                 5
   
Data 3         Score
="very low    "                    0
="low"                            1
="medium"                 2
="high"                         3
="very high"                 4

Après j'additionne les scores et je fais une moyenne.

Pour le début, j'ai voulu obtenir le score de la colonne contenant les "Data 1"

Code:

=SI(ET(A1<=1000;A1>=0);0;SI(A1<=10000;A1>1001);1;SI(A1<=50000;A1>10001);2;SI(A1<=100000;A1>50001);3;SI(A1>100001);4)

Réponse de monsieur excel ? Trop d'arguments !

Ce n'est que le début et excel me le fait payer durement sad

Une grande âme, un génie, voir un comptable pratiquant l'excel avec une dévotion religieuse pour m'aider ?



Annonces sponsorisées :

Quand on ne sait rien, on peut tout de même trouver des choses, avec de l'imagination. [Boris Vian]
  • |
  • Répondre

#0 Pub

 #2 - 16-06-2012 21:27:10

shadock
Elite de Prise2Tete
Enigmes résolues : 39
Messages : 3319

P2T EExcel (argh!)

Tu es sur que l'on puisses mettre autant de "SI" d'affiler ?
Si tu mets tout ces "SI" dans la même case tu n'auras pas de résultat. Ou alors mets un "SINON" s'il y en a un smile

Shadock


"L'expérience est une lanterne qui n'éclaire que celui qui la porte." L-F. Céline

 #3 - 16-06-2012 21:33:52

Seanbateman
Professionnel de Prise2Tete
Enigmes résolues : 21
Messages : 321
Lieu: Toujours à l'énigme 3

o2t excel (argh!)

Je crois qu'avec un "SINON" ça réduit encore plus les possibilités :
SI XX<=1000;1;2 (le deuxième ";" fait office de sinon)

sad


Quand on ne sait rien, on peut tout de même trouver des choses, avec de l'imagination. [Boris Vian]

 #4 - 16-06-2012 21:51:36

shadock
Elite de Prise2Tete
Enigmes résolues : 39
Messages : 3319

PT Excel (argh!)

Et il t'affiche quoi Excel à la fin du calcul ? hmm


"L'expérience est une lanterne qui n'éclaire que celui qui la porte." L-F. Céline

 #5 - 16-06-2012 21:54:29

Seanbateman
Professionnel de Prise2Tete
Enigmes résolues : 21
Messages : 321
Lieu: Toujours à l'énigme 3

P2TT Excel (argh!)

Avec celui présent plus haut, qu'il y a trop de variables, trop de SI je crois...

Et sinon avec ça (qu'excel accepte) :

Code:

=SI(A1>250000<=500000;1;SI(A1>500000<=1000000;2;SI(A1>1000000<=2000000;3;SI(A1>2000000;4;0))))

Cela passe, mais ne fonctionne pas sad


Quand on ne sait rien, on peut tout de même trouver des choses, avec de l'imagination. [Boris Vian]

 #6 - 16-06-2012 21:55:14

shadock
Elite de Prise2Tete
Enigmes résolues : 39
Messages : 3319

o2t excel (argh!)

En fait tu n'as pas respecté le codage :
Un si sous Excel il me semble se fait plutôt :

Si(Test;valeur si vrai;valeur si faux)

Shadock smile


"L'expérience est une lanterne qui n'éclaire que celui qui la porte." L-F. Céline

 #7 - 16-06-2012 22:08:06

franck9525
Elite de Prise2Tete
Enigmes résolues : 48
Messages : 1922
Lieu: UK

p2r excel (argh!)

le plus simple est de creer ta propre fonction.
Dans le worksheet tu l'appelles simplement par son nom
=my_rank1(A1)

tu crées une macro toute simple dans un module
Function my_rank1(Mynum)
select case Mynum
  case <=1000
  my_rank1 = 0
  case <=10000
  my_rank1 = 1
  case <=50000
  my_rank1 = 2
  ...
  case else
  my_rank1 = 5
end select
end function


The proof of the pudding is in the eating.

 #8 - 16-06-2012 22:19:20

elpafio
Expert de Prise2Tete
Enigmes résolues : 42
Messages : 828

p2t excel (argj!)

En formule, ça devrait donner ceci:

Code:

=SI(ET(A1<=1000;A1>=0);0;
SI(A1<=10000;1;
SI(A1<=50000;2;
SI(A1<=100000;3;4))))

Rendez les choses aussi simples que possible, mais pas plus simples. Albert Einstein

 #9 - 16-06-2012 22:27:28

Arrakis
Elite de Prise2Tete
Enigmes résolues : 49
Messages : 1149
Lieu: Dark side of the moon

P2T Excel a(rgh!)

Hello smile

Je ne suis pas sûr d'avoir tout bien compris ce que tu veux faire avec les 3 Data,
mais en revanche, cconcernant ton code pour Data 1, tu n'as pas besoin de ET

Code:

=SI(A1>100000;4;SI(A1>50000;3;SI(A1>10000;2;SI(A1>1000;1;0))))

EDIT.

Oops... Grillé par Elpafio, qui propose la même mais dans l'autre sens smile


www.enigmes.ch

 #10 - 16-06-2012 22:46:27

Seanbateman
Professionnel de Prise2Tete
Enigmes résolues : 21
Messages : 321
Lieu: Toujours à l'énigme 3

P2T Excel argh!)

Merci de vos réponses !
@elpafio: Je viens de test ta solution et cela ne marche pas, j'ai fait


Code:

=SI(ET(A1<=500000;A1>=250000);1;SI(A1<=1000000;2;SI(A1<=2000000;3;SI(A1>2000000;4;0))))

En A1 il y a 39000 et le résultat affiché est "2" au lieu de 0 sad

EDIT : Arrakis WIN ! smile
Ca marche, ouf. Me reste plus que le reste, si je ne montre plus signes de vie dans 5 jours merci de me considérer cliniquement mort. big_smile


Quand on ne sait rien, on peut tout de même trouver des choses, avec de l'imagination. [Boris Vian]

 #11 - 16-06-2012 22:55:35

elpafio
Expert de Prise2Tete
Enigmes résolues : 42
Messages : 828

P2T Excel (arhg!)

Tu n'as pas du bien recopier ce que j'ai écrit (ou pas dans le bon ordre ou pas avec les mêmes nombres):

Code:

=SI(ET(A1<=1000;A1>=0);0;
SI(A1<=10000;1;
SI(A1<=50000;2;
SI(A1<=100000;3;4))))

Pour Data 1, 39000 doit bien donner un résultat de "2" si on lit le post initial.


Rendez les choses aussi simples que possible, mais pas plus simples. Albert Einstein

 #12 - 16-06-2012 22:59:54

Arrakis
Elite de Prise2Tete
Enigmes résolues : 49
Messages : 1149
Lieu: Dark side of the moon

P2T Excel (agh!)

EDIT : Arrakis WIN !

Cool smile

En fait, la règle quand tu imbriques les SI, c'est qu'il y a une valeur "si vrai" par condition, et une unique valeur "si faux" à la fin, quand la cellule ne correspond à aucune des conditions. De plus, une cellule qui répond à la première condition ne sera pas soumise à la deuxième, et ainsi de suite.


www.enigmes.ch

 #13 - 17-06-2012 00:35:45

Seanbateman
Professionnel de Prise2Tete
Enigmes résolues : 21
Messages : 321
Lieu: Toujours à l'énigme 3

P2T xEcel (argh!)

@elpafio : Effectivement, j'ai sûrement dû faire une connerie. Mais cela marche aussi avec le modèle d'Arrakis (sans ET), pourquoi ? Je ne sais pas, mais ma philosophie c'est "ça fonctionne alors ça marche". big_smile

PS : Quel idée d'excel d'avoir traduit les opérateurs aussi !

Merci à vous !


Quand on ne sait rien, on peut tout de même trouver des choses, avec de l'imagination. [Boris Vian]

 #14 - 17-06-2012 03:34:56

Seanbateman
Professionnel de Prise2Tete
Enigmes résolues : 21
Messages : 321
Lieu: Toujours à l'énigme 3

PT Excel (argh!)

Je n'en finirais jamais smile
Maintenant ça fait une heure que je bloque sur une fonction qui me permette d'afficher 1 si A1 contient le mot MOT1 OU MOT2 OU MOT3 et je n'y arrive pas sad

Sur papier ça fait un truc du genre : SI A1 ="MOT1"OU"MOT2"OU"MOT3" ALORS 1 SINON 0 mais sur excel c'est autre chose.

Il est tard, je vais me coucher et enlever excel de ma mémoire

EDIT : Pour les curieux j'ai trouvé :

Code:

=SI(ESTNUM(CHERCHE("mot1";A1))+ESTNUM(CHERCHE("mot2";A1));"1";"0")

Quand on ne sait rien, on peut tout de même trouver des choses, avec de l'imagination. [Boris Vian]

 #15 - 17-06-2012 05:55:28

NickoGecko
Elite de Prise2Tete
Enigmes résolues : 49
Messages : 1747

P2T Excel (argh!!)

coucou !

Code:

=SI(OU(A1="MOT1";A1="MOT2";A1="MOT3");"1";"try again")

A+


Il aurait pu pleuvoir, con comme il est ! (Coluche)

 #16 - 18-06-2012 11:03:28

Klimrod
Elite de Prise2Tete
Enigmes résolues : 40
Messages : 3771
Lieu: hébesphénorotonde triangulaire

P2T Excel (arghh!)

Bonjour,

Les formules les plus simples n'utilisent même pas la fonction SI !

Pour Data1 : la formule à taper dans la barre de formule en A2 :
=(A1>1000)+(A1>10000)+(A1>50000)+(A1>100000), et à la fin, au lieu d'appuyer sur Enter, tu appuies sur Shift+Control+Enter.

Idem pour Data2 : la formule à taper dans la barre de formule en A2 :
=(A1>=1)+(A1>50)+(A1>100)+(A1>200)+(A1>500), et à la fin, au lieu d'appuyer sur Enter, tu appuies sur Shift+Control+Enter.

Pour Data3 : la formule à taper dans la barre de formule en A2 :
=0*(A1="very low")+1*(A1="low")+2*(A1="medium")+3*(A1="high")+4*(A1="very high"), et à la fin, au lieu d'appuyer sur Enter, tu appuies sur Shift+Control+Enter.

Pour ta recherche de mots : la formule à taper dans la barre de formule en A2 :
=(SIERREUR(CHERCHE("mot1";A1);0)>0)+(SIERREUR(CHERCHE("mot2";A1);0)>0), et à la fin, au lieu d'appuyer sur Enter, tu appuies sur Shift+Control+Enter.
Si tu tapes en A1 le texte "cette cellule contient mot1 et contient mot2", tu obtiendras 2 en A2 (car Excel a trouvé les deux mots).

Remarque bien qu'il faut terminer la formule par la combinaison de touches Shift+Control+Enter (au lieu du traditionnel Enter)...

Klim.


J'ai tant besoin de temps pour buller qu'il n'en reste plus assez pour bosser. Qui vit sans folie n'est pas si sage qu'il croit.
 

Réponse rapide

Rédige ton message
| | | | Upload | Aide
:) :| :( :D :o ;) :/ :P :lol: :mad: :rolleyes: :cool:
Sécurité

Répondez à la devinette suivante : 

Le père de toto a trois fils : Pif, Paf et ?

Sujets similaires

Sujet Date Forum
P2T
P2T et vie de couple par MthS-MlndN
06-03-2010 Blabla
P2T
Un dîner presque P2T. par FRiZMOUT
30-06-2010 Blabla
23-09-2010 Blabla
14-03-2009 Blabla
P2T
28-02-2008 Blabla
P2T
Sur P2T pas de DSK par Seanbateman
16-05-2011 Blabla
07-05-2012 Blabla
03-12-2010 Blabla
10-11-2009 Blabla

Pied de page des forums

P2T basé sur PunBB
Screenshots par Robothumb

© Copyright 2002–2005 Rickard Andersson

Prise2Tete Forum Statistiques Liste des membres Hall of Fame Contact
© Prise2tete - Site d'énigmes et de réflexion.
Un jeu où seules la réflexion, la logique et la déduction permettent de trouver la solution.

Flux RSS de Prise2Tete Forum Jeux & Prise2Tete Test & Prise2Tete Partenariat et Publicité sur Prise2Tete